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 Illustrator Training – Part 1 

Activity 1: What is Illustrator 

Activity 2: Getting Started in Illustrator 

Activity 3: Drawing Basic Shapes 

Activity 4: Drawing with Pencil Tool 

Activity 5: Drawing with Pen Tool 

 Illustrator Training – Part 2 

 Activity 6: Using Brushes 

 Activity 7: Creating Compound Paths 

 Activity 8 Working with Color and Strokes 

 Activity 9: Editing Objects, Layers & Groups 

 Activity 10: Transparency & Graphic Styles 

 Illustrator Training – Part 3 

 Activity 11: Transforming & Moving Objects 

 Activity 12: Basic Text 

 Activity 13: Blending Shapes & Colors 

 Activity 14: Photorealism with Gradient Mesh 

 Activity 15: Using the Symbol Tools 

 Illustrator Training – Part 4 

 Activity 16: Creating Special Effects 

 Activity 17: Applying 3D Extrude & Bevel 

 Activity 18: Distort using Warp Effects 

 Activity 19: Applying Live Paint 

 Activity 20: Masking using Clipping Path/ Opacity Mask 

 Activity 21: Saving & Printing 

 Activity 22: Final Project – Designing a Logo 



Act. 1: What is Illustrator? 

 
Illustrator is a vector drawing program. It is often 

used to draw illustrations, cartoons, diagrams, charts 

and logos.  

 

 Unlike bitmap images that stores information in a 

grid of dots, Illustrator uses mathematical equations 

to draw out the shapes. This makes vector graphics 

scalable without the loss of resolution. 

 



Advantages of Vector Graphics 

 
 Scalable without resolution loss 

 Lines are crisp and sharp at any sizes 

 Print at high resolution 

 Smaller file size 

 Good for drawing illustrations 

 Disadvantages of Vector Graphics 
 
 Drawings tend to look flat and cartoon 

 Hard to produce photo realistic drawings 

 

 



Common Uses for Illustrator 

 1) Designing Logos 

 



Common Uses for Illustrator 

 2) Drawing Maps 

 



Common Uses for Illustrator 

 3) Drawing Illustrations 

 



Common Uses for Illustrator 

 4) Infographics 

 



Common Uses for Illustrator 

 5) Photorealistic Drawings 

 



Common Uses for Illustrator 

 6) Packaging Design 



Act. 2: Getting Started in 

Illustrator 



Illustrator Workspace 



T
o

o
lb

o
x
 



Floating Palette 



Saving AI Files 

Let’s select the type and click on the artboard and type some 

text. After that go to File>Save. Select Adobe Illustrator(*.AI) 

for file type and name it “First Drawing”. Click Ok after that. 

Leave the rest of the settings at default. You have successfully save 

your first file. To make any more changes you can simply open the 

Adobe Illustrator file. 

 



Act. 3: Drawing Basic Shapes 

 How to use the shape tools to draw our 

basic shapes in illustrator? 

 

 How to select a basic shape? 



Selection Tools – 2 Types: 

 Selection Tool: Used for selecting and moving a shape. It can also 

be used to resize a shape. 

 Direct Selection Tool: Selects a single anchor point instead of 

the whole shape. Used for editing anchor point of a shape. Click 

once on a point to select and hold Shift to select multiple anchor 

points. 

 



Shape Tools  



Understanding Fill & Stroke 



Changing Fill Color 



Removing Stroke 



Constrain Proportions 



Resizing Shapes 

 select the shape using the Selection Tool and a 

bounding box will appear. Drag the corner anchor 

point to resize it. To constrain to proportion 

while resizing (hold Shift). Also hold Alt/Option 

if your want to resize from the same position 



Rotating Shapes 

 Select the shape (Selection Tool)  

 Move your cursor near the anchor corner and a 

rotation icon will icon, click and turn it to rotate the 

square. To snap at 45 degrees increment, hold Shift and 

turn. 

 



More Options for Shape Tools 

 Select the Star Tool. Click once on the artboard 

and an option will pop up. Enter the same 

values below and click Ok.  

 



Conclusion: 

 Almost all the objects found in our daily 

life can be built from combining using the 

basic shape tools.  

 Compound Paths will help us create more 

complicated shapes by adding and 

subtracting from the basic shapes. 

 



Act. 4: Drawing with Pencil Tool 

 

 We can quickly draw shapes and lines quickly 
using the Pencil Tool.  

 

 This lesson will show you some of the tricks 
in drawing smooth and fluid lines. 



Drawing a Line 



Closing Paths with Pencil Tool 

 Hold Alt/Option as your Pencil Tool 
reaches the start point. A circle icon will 
appear next to the Pencil Tool to indicate 
path closure. 



Smoothing Jaggy Lines 
 hold Alt/Option to turn the Pencil Tool to 

Smooth Tool. Then draw over the area of 

the lines which you would like to 

smoothen. 



Reshaping Path 

 Make sure your path is selected and use the 

Pencil Tool to redraw the parts you would like 

to reshape. Note that the start and end path 

must be close to the original path to make it 

work. 

 



Pencil Tool Preferences (double click 

on the Pencil Tool) 

 Fidelity: 
Determines how 
close the path is 
drawn to your 
mouse movement. 
Set it at a higher 
fidelity if you’re not 
good at drawing 
with your mouse. 

 Smoothness: The 
higher you set for 
smoothness, the 
less anchor point it 
produces. Thus, 
producing a 
smoother line. 

 



Act. 5: Drawing with Pen Tool 

 The Path Tool will 
be the hardest tool 
to learn in 
Illustrator. It usually 
take weeks to learn 
and beginners 
always end up in 
frustration while 
figuring how it 
works. So don’t give 
up and practice it 
every day and soon 
you will be able to 
draw any shape. 

 



Drawing Straight Lines 
 Select the Pen Tool and click once to add the first 

anchor point. Move your mouse to the next position 

and click again to create the second point. The two 

anchor points will be connected together. Continue 

doing this to create a W shape as shown. To draw a new 

line, click the Selection Tool (The Black Arrow Icon) and 

click back the Pen Tool again. 

 



Closing a Path 

 To close a path, click back the starting 

point to close the shape. 

 



Drawing a Curved Line 

 Click and drag to put out the handles to 

create a smooth anchor point. 

 



Changing Path Directions 

 Click and drag to create a smooth anchor point. 

Without releasing your mouse, hold Alt/Option and 

drag the handle up to change the path direction. 

 



Drawing a Circular Path 

 Click and drag 

to create a 

smooth 

anchor point. 

Continue 

adding points 

and click back 

the starting 

point to close 

the path. 

 



Adding Anchor Points 

 With the Pen Tool selected, go near the path where you 

want to add a new anchor point. A plus sign will appear 

next to the pen, click on the path to create a new 

anchor point. 

 



Removing Anchor Points 

 To remove point, move your Pen Tool close to an 

anchor. A minus sign will appear next to the pen. Click 

on the anchor point to delete it. 

 



Converting Anchor Points 

 To convert a smooth anchor point to a sharp anchor 

point, move your Pen Tool near the anchor and hold 

Alt/Option and your Pen Tool will change to an arrow 

shape. Click on the smooth anchor to convert it to an 

anchor point. Click and drag on the anchor point again 

to change it back to a smooth anchor point. 

 



Moving Anchor Points 

 Select the Direct Selection Tool and click and 

on anchor you want to move. Click and drag to 

change positions. 

 



Changing Anchor Directions 
 Pen Tool - hold Ctrl/Command to quickly change the Pen 

Tool to Direction Selection Tool. Select the anchor point 

you want to edit. The anchor handle will appear. Now 

release Ctrl/Command and hold Alt/Option to change it to 

Convert Anchor Tool. Click and drag the handles to change 

the direction. 

 





Tips for Using Pen Tool 

 Use as little anchor points your need to 
create your shape 

 Add anchor points where there is a 
change in direction of the line/curve 

 Use shortcuts like Alt/Option or 
Ctrl/Command to quickly swap to other 
tools to edit your path 

 Hold shift to lock your path while adding 
new anchor point for 45-degree 
increments. 

 



Act. 6: Using Brushes 

 Add styles to your lines.  

 

 It can also be used to mimic calligraphy, 

crayon and brush strokes. 

 

 Add more life to your line works. 

 



Applying Brush Stroke 

 Select the Brush Tool and draw your object. 

Then go to your Brushes Palette and select the 

crayon brush to apply the effect. 

 



Calligraphy Brush Stroke 

 To apply a calligraphy brush stroke, draw 

your path and select the calligraphy brush. 

Increase the Stroke to make it thicker. 

 



Calligraphy Brush 

Options 
 To make 

changes to your 
calligraphy 
brush, you can 
double click the 
Calligraphy 
Brush to pop up 
the calligraphic 
brush options. 
Drag the brush 
to change the 
angle in the 
thumbnail. 
Change the 
Diameter makes 
it thicker. 

 



Create a Border Pattern 

 Draw a rectangle and pick the border 

pattern. This will create a frame for it. 

 



Creating a New Pattern Brush 
 Draw a Star and drag it to the Brushes Palette. A New 

Brush selection appears. Choose New Pattern Brush for 

it. 

 



Applying Pattern Brush 

 Draw a circle and apply our new brush stroke. 

 



Applying Pattern 

Brush 

 Next draw a 

line path and 

apply the 

brush stroke. 

Double click 

the star brush 

from your 

brushes and 

set Scale and 

Spacing to 20% 

to get the 

effect below. 



are very good for 

aligning objects and creating 

borders. So experiment with it and 

have fun! 



Act. 7: Creating Compound 

Paths 

 to combine or subtract shapes 
to create what we need. 

 Compound path is made out 
of at least two objects.  

 add, subtract and intersect 
shapes to form a compound 
path. 
 

 

 





Creating an Ancient Key Using 

Compound Path -Turning on the Grids 

 
 Go to View>Show Grid to turn on the grids, 

then go and turn on Snap to Grid. With the grid 

and snapping turned on, you can easily snap 

objects to the grid. 

 



 First draw a Circle using your Shape Tools, 

hold Alt/Option as you click and drag a 

new copy beside it. 

 



 Duplicate a new circle and place it on top. 

 



 Next, select the 

Rectangle Tool 

and continue 

building up your 

key shape. 

 





 Swap the Fill 

and Stroke for 

the object, this 

will show you 

all the objects 

we have. 

 



 You can still make changes to the compound path at this 

stage. Try moving the top circle below to see how it 

works.  

 



 Using the Selection Tool, select the whole shape and go 

to Window>Pathfinder to bring up the Pathfinder. Select 

Add to shape to combine the objects. 

 



 Next we will swap it back to black fill again, 

draw a circle in the middle which we will punch 

a new hole there. Select both shapes and select 

Subtract from shape area. 

 



 Here is the final illustration. 

 



Act. 8 : Working with Color and 

Strokes 

 
 Filling Color Using 

Swatches 

 

 Filling Color Using 

Color Picker 

 

 Changing Fill and 

Stroke Using 

Control Palette 

 

 



Stroke Caps 
 The Stroke Caps determine the start and end points of 

a stroke. This applies to open paths only. You can choose 

between a Butt, Round, or Projecting cap. 

 



Miter Limit 

 The stroke’s 

Miter Limit 

specifies the 

appearance 

for the joins 

in a shape.  

 



Applying Gradient to Objects 

 go to the Tool Palette and set it to 

Gradient Fill 



 Open up your Gradient and Color Palette. By 

default it is a Grayscale gradient. Click Options 

icon at the corner and change it to RGB mode. 

 



 After we switched to RGB, create a new swatch to pick 

the color. Choose a dark blue for it. 

 



 Do the same for the start point, change it to 

RGB and choose a light blue. 

 



 To add a new gradient stop to the gradient, click 

right below the gradient ramp to create a new 

stop. Change it to white color. To remove it, you 

can drag the stop out of the Palette. 

 



 To change the direction of the gradient, select the 

Gradient Tool from the Tool Palette. Change the value 

of the angle in the direction you want the gradient                                                  

to follow. 

 



Pattern Fill 

 
 To create seamless pattern fill, we can choose 

the pattern fill from the Swatches. 

 



Conclusion 

 Using radial and linear 
gradient, we can achieve 
a lot of realism to our 
artwork. Radial patterns 
can add depth and 
volume to circle, and 
linear pattern can used 
to create volume for 
cylinders. Here is an 
example of gradients 
used to create a jingle 
bell. 

 

http://refer.istockphoto.com/ta.php?lc=055041042431004651&atid=328|BannerID=328|ReferralMethod=Link&url=http://www.istockphoto.com/stock-illustration-4483791-3d-gold-bells.php


Act. 9 : Editing Objects, Layers 

& Groups 
 

 As you start 
working on 
complicated 
illustrations, 
layers will start to 
build up. 

 

  Group and 
arrange them so 
that you can 
move and edit 
the layers easily.  

http://refer.istockphoto.com/ta.php?lc=055041042431004651&atid=328|BannerID=328|ReferralMethod=Link&url=http://www.istockphoto.com/stock-illustration-3006145-facial-care.php


Layers Palette 

 Access your Layers Palette from 
Window>Layers.  

 Visibility Icon: Click to hide/unhide layer 

 Lock Icon: Click the lock to lock the layer 

 Layer Name: Double click to rename it 

 Target Indicator: Click to select layer 

 Delete Layer: Click to delete layer 

 New Layer: Add new layer on top 

 New Sublayer: Add new sublayer under 
Layer 1 





Arranging Objects 

 To bring a layer on top, select the layer 

and drag it to the top.  

 



Grouping Objects 

 Ctrl/Command+G (to group) 

 Ctrl+Shift+G/Command+Shift+G (ungroup) 

 



Appearance Palette 

 shows what effect is applied to a layer. 

 Add New Fill or Add New Stroke to the 

whole layer or individual objects. 

 Windows>Appearance to open  

 Let’s see how it looks when we apply a 

new fill. Click the option icon and choose 

Add New Fill. 

 





 After we set the Fill with pink color, it 

turns the whole layer to pink. 

 



Act. 10: Transparency & 

Graphic Styles 
 

 

 to create eye catching effects 

 

 to enhance your illustrations 

 



Adding Transparency 

 Window>Transparency to open. 

 Stack a few objects and set it to a lower opacity 

of 50% for the underlying color to show 

through. 

 



Blending Modes for Objects 

 Blending modes 

(also in Ps) let you 

vary the ways that 

the colors of 

objects blend with 

the colors of 

underlying objects.  

 



Button Reflection Using Screen 

 First draw a circle and apply a gradient of 

light to dark orange to it. 



 Draw another circle on top and apply a 

gradient from black to white. 

 



 Finally, select the black to white circle and 

change the blending mode to Screen. And 

you’re done! 

 



Applying Graphic Styles 

 Illustrator has some built in graphic styles which you are 

quickly apply to your objects. Once you have created an 

object style, you can apply it across different objects. 

 



 To see the attributes of an graphic styles, go 

Window>Appearance. Here we can see that 

there are 3 fills with effects(fx icon) applied.  

 



Act. 11: Transforming & Moving 

Objects 
 Resizing Objects 

◦ Method 1: Select the object with Selection 

Tool and the bounding box will appear. Select 

the corner handle and resize while holding 

Shift to constrain proportion. 

 



Act. 12: Basic Text 

 

 Typing Text Using Point Text 

 

 Text wrap 



Act. 13: Blending Shapes & 

Colors 
 

 Blend Tool does the trick of creating 

smooth transition between objects.  

 

 You can blend open paths to create line 

effects and blend shapes to create realistic 

shadings.  

 



Act. 14: Photorealism with 

Gradient Mesh 
 allows you to create shapes with gradients. And 

many artist has been able to create photo realistic 

drawings of people, products and vehicles just by 

using Gradient Mesh.  

 



Act. 15: Using the Symbol Tools 

 Symbols help you to create repeated 

design elements easily. 



Act. 16: Creating Special Effects 

 Filters and live effects create lots of special effects 

instantly (smooth out sharp corners, create warp text, 

add drop shadows and make textures) 

◦ Live Effects: When you apply live effects to objects 

you can still continue to modify the effects and 

objects. You will need to expand the object break it 

into paths again. 

◦ Filters: When you apply filters, you can’t make 

changes to the effect anymore. It is already expanded. 

 



Act. 17: 

Applying 

3D 

Extrude 

& Bevel 



Act. 18 : Distort using Warp 

Effects 



Act. 19: Applying Live Paint 

 

 With Live Paint, you can freely paint your 

artwork.  

 

 It is like painting a kid’s coloring book 

where you have the line art and you start 

filling them will different colors.  



Act. 20 : Masking using Clipping 

Path/ Opacity Mask 
 

 With Clipping Mask and Opacity Mask, 

you can quickly mask away any unwanted 

areas you wish to hide.  



Act. 21: Saving & Printing 

 

 Savings Files Using Crop Area 

 

 EPS file which is the universal format for 

saving vector graphics. 

 





 http://www.creativebloq.com/digital-

art/illustrator-tutorials-1232697 

 

 http://abduzeedo.com/create-playstation-

controller-illustrator 
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